Virtual Port Channel (vPC) Configuration on Cisco Nexus

As per Cisco documentation:
A virtual PortChannel (vPC) allows links that are physically connected to two different Cisco Nexus devices to appear as a single Port Channel to a third device. The third device can be a Cisco Nexus 2000 Series Fabric Extender or a switch, server, or any other networking device.
A vPC can provide Layer 2 multipathing, which allows you to create redundancy by increasing bandwidth, enabling multiple parallel paths between nodes and load-balancing traffic where alternative paths exist.

For this example, we will use a layer 2 switch as the third device,e.g.4900 Cisco series switch.

Diagram:

vpc

Pre-config the management interface

Switch1:

vrf context management
ip route 0.0.0.0/0 192.168.0.65

interface mgmt0
vrf member management
ip address 192.168.0.70/28

Switch2:

vrf context management
ip route 0.0.0.0/0 192.168.0.65

interface mgmt0
vrf member management
ip address 192.168.0.71/28

 

Switch1 Configuration:
1.Enable vpc

feature vpc

2. Create a vpc domain

vpc domain [domain-ID]

3. Configure the peer-keepalive

peer-keepalive destination [peer-IP]

4. Configure role-priority

role priority [value from 1 to 65636]

5. Configure system-priority

system-priority [value from 1 to 65535]

7.Configure Port-channel facing the vpc peer

interface port-channel [number]
vpc peer-link

8. Configure Port-channel facing the downstream device

interface port-channel
vpc [value from 1 to 4096]

Sample configuration for Switch1:

feature vpc

vpc domain 100
peer-switch
role priority 90
system-priority 4000
peer-keepalive destination 192.168.0.71
peer-gateway
fabricpath switch-id 200
fabricpath multicast load-balance
ipv6 nd synchronize
ip arp synchronize

interface port-channel1001
description Connection to Switch2
switchport
switchport mode fabricpath
spanning-tree port type network
vpc peer-link

interface port-channel8
description Connection to L2Switch
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20,30
vpc 888

Sample configuration for Switch2:

feature vpc

vpc domain 100
peer-switch
role priority 100
system-priority 4000
peer-keepalive destination 192.168.0.70
peer-gateway
fabricpath switch-id 200
fabricpath multicast load-balance
ipv6 nd synchronize
ip arp synchronize

interface port-channel1001
description Connection to Switch1
switchport
switchport mode fabricpath
spanning-tree port type network
vpc peer-link

interface port-channel8
description Connection to L2Switch
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20,30
vpc 888

Verification:

show vpc
show  vpc role
show vpc peer-keepalive

Sample Output:

Switch1:

Switch1# show vpc
Legend:
(*) – local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
vPC+ switch id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
vPC fabricpath status : peer is reachable through fabricpath
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Enabled
Peer gateway excluded VLANs : –
Dual-active excluded VLANs : –
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
Fabricpath load balancing : Enabled
Port Channel Limit : limit to 244

vPC Peer-link status
———————————————————————
id Port Status Active vlans
— —- —— ————————————————–
1 Po1001 up 5-10,14-30,32-58,70-80,84-85,87-89

vPC status
——————————————————————————-
id Port Status Consistency Reason Active vlans vPC+ Attribute
— —- —— ———– —— ———— ————–

8  Po10 up success success 10,20,30 DF: Partial,

Switch1# show vpc role

vPC Role status
—————————————————-
vPC+ role : primary
vPC system-mac : 00:11:22:aa:bb:cc
vPC system-priority : 4000
vPC local system-mac : 33:44:aa:55:66:77
vPC local role-priority : 90

Switch1# show vpc peer-keepalive

vPC keep-alive status : peer is alive
–Peer is alive for : (63150143) seconds, (165) msec
–Send status : Success
–Last send at : 2021.08.09 11:34:51 180 ms
–Sent on interface : mgmt0
–Receive status : Success
–Last receive at : 2021.08.09 11:34:51 181 ms
–Received on interface : mgmt0
–Last update from peer : (0) seconds, (881) msec

vPC Keep-alive parameters
–Destination : 192.168.0.71
–Keepalive interval : 1000 msec
–Keepalive timeout : 5 seconds
–Keepalive hold timeout : 3 seconds
–Keepalive vrf : management
–Keepalive udp port : 3200
–Keepalive tos : 192

Switch2:

Switch2# show vpc
Legend:
(*) – local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
vPC+ switch id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
vPC fabricpath status : peer is reachable through fabricpath
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Enabled
Peer gateway excluded VLANs : –
Dual-active excluded VLANs : –
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
Fabricpath load balancing : Enabled
Port Channel Limit : limit to 244

vPC Peer-link status
———————————————————————
id Port Status Active vlans
— —- —— ————————————————–
1 Po1001 up 5-10,14-30,32-58,70-80,84-85,87-89

vPC status
——————————————————————————-
id Port Status Consistency Reason Active vlans vPC+ Attribute
— —- —— ———– —— ———— ————–

8  Po10 up success success 10,20,30 DF: Partial,

Switch2# show vpc role

vPC Role status
—————————————————-
vPC+ role : secondary
vPC system-mac : 00:11:22:aa:bb:cc
vPC system-priority : 4000
vPC local system-mac : 33:44:aa:55:66:99
vPC local role-priority : 100

Switch2# show vpc peer-keepalive

vPC keep-alive status : peer is alive
–Peer is alive for : (63150427) seconds, (736) msec
–Send status : Success
–Last send at : 2021.08.09 11:39:35 415 ms
–Sent on interface : mgmt0
–Receive status : Success
–Last receive at : 2021.08.09 11:39:35 416 ms
–Received on interface : mgmt0
–Last update from peer : (0) seconds, (972) msec

vPC Keep-alive parameters
–Destination : 192.168.0.70
–Keepalive interval : 1000 msec
–Keepalive timeout : 5 seconds
–Keepalive hold timeout : 3 seconds
–Keepalive vrf : management
–Keepalive udp port : 3200
–Keepalive tos : 192

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *