BGP Configuration between Huawei, Juniper and Cisco Routers

Here’s the basic BGP (eBGP) configuration of  connecting 3 different router vendors namely Huawei, Juniper and Cisco Routers. Assuming we connect via their physical interfaces and incoming and outgoing policies are basically allow all.

Sample Configuration

Huawei
<Huawei>system-view
Enter system view, return user view with return command.
[~Huawei]

interface GigabitEthernet1/0/0
description Connection to Cisco
ip address 192.168.0.1 255.255.255.252

interface GigabitEthernet1/0/1
description Connection to Juniper
ip address 192.168.1.1 255.255.255.252

xpl route-filter Cisco-Import
approve
end-filter

xpl route-filter Cisco-Export
approve
end-filter

xpl route-filter Juniper-Import
approve
end-filter

xpl route-filter Juniper-Export
approve
end-filter

BGP Configuration:
bgp 65510
router-id 1.1.1.1
graceful-restart
private-4-byte-as disable
peer 192.168.0.2 as-number 65511
peer 192.168.0.2 description to Cisco BGPv4
peer 192.168.0.2 password cipher <password here>

peer 192.168.1.2 as-number 65512
peer 192.168.1.2 description to Juniper BGPv4
peer 192.168.1.2 password cipher <password here>
#
ipv4-family unicast
peer 192.168.0.2 enable
peer 192.168.0.2 route-filter Cisco-Import import
peer 192.168.0.2 route-filter Cisco-Export export
peer 192.168.0.2 route-limit 100 alert-only

peer 192.168.1.2 enable
peer 192.168.1.2 route-filter Juniper-Import import
peer 192.168.1.2 route-filter Juniper-Export export
peer 192.168.1.2 route-limit 100 alert-only

commit

Juniper
fnt@Juniper-re0> configure
Entering configuration mode
Users currently editing the configuration:
fnt@Juniper-re0#

set interfaces ge-0/0/0 description “Connection to Huawei”
set interfaces ge-0/0/0 unit 0 family inet address 192.168.1.2/30

set routing-options autonomous-system 65512

set policy-options prefix-list PREFIXLIST 192.168.1.0/30

set policy-options policy-statement Huawei-in term 1 from as-path 65510
set policy-options policy-statement Huawei-in term 1 then accept
set policy-options policy-statement Huawei-in term DEFAULT-REJECT then reject

set policy-options policy-statement Huawei-out term 1 from prefix-list PREFIXLIST
set policy-options policy-statement Huawei-out term 1 then accept
set policy-options policy-statement Huawei-out term REJECT then reject

BGP Configuration:
set protocols bgp group Huawei-BGP type external
set protocols bgp group Huawei-BGP family inet unicast prefix-limit maximum 100
set protocols bgp group Huawei-BGP family inet unicast prefix-limit teardown 80
set protocols bgp group Huawei-BGP authentication-key <password here>
set protocols bgp group Huawei-BGP peer-as 65510

set protocols bgp group Huawei-BGP neighbor 192.168.1.1 description Huawei BGPv4
set protocols bgp group Huawei-BGP neighbor 192.168.1.1 import Huawei-in
set protocols bgp group Huawei-BGP neighbor 192.168.1.1 export Huawei-out

commit


Cisco (IOS-XR)

RP/0/RSP0/CPU0:Cisco#configure
RP/0/RSP0/CPU0:Cisco(config)#

interface Gi0/0/0
description Connection to Huawei
ipv4 address 192.168.0.2 255.255.255.252

route-policy Huawei-in
pass
end-policy

route-policy Huawei-out
pass
end-policy

BGP Configuration:

router bgp 65511
address-family ipv4 unicast
network 192.168.0.0/30
redistribute connected

neighbor 192.168.0.1
remote-as 65510
password clear <password here>
description to Huawei BGPv4
address-family ipv4 unicast
route-policy Huawei-in in
maximum-prefix 100 80 warning-only
route-policy Huawei-out out

commit

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *