OSPF and OSPFv3 Configuration on Huawei Routers

Here is sample basic IPv4 & IPv6(OSPFv3) Open Shortest Path First (OSPF) configuration between 2 Huawei Routers with MD5 authentication.

Fig1.

OSPF

RouterA Configuration:

  1. Configure physical interface

<RouterA>interface 100GE6/0/0
<RouterA>description Connection to RouterB
<RouterA>undo shutdown
<RouterA>eth-trunk 1
<RouterA>undo lldp enable
<RouterA>undo dcn

2. Configure the Eth-Trunk IPv4/IPv6 address

<RouterA>interface Eth-Trunk1
<RouterA>description Eth-Trunk to RouterB
<RouterA>ipv6 enable
<RouterA>ip address 192.168.10.1 255.255.255.252
<RouterA>ipv6 address fdfe:13bb:8abc:a00:8::2a/127
<RouterA>mode lacp-static

3. Configure the OSPF (IPv4) process (with optional parameters)

<RouterA>ospf 8888 router-id 172.16.1.1
<RouterA>bfd all-interfaces min-tx-interval 100 min-rx-interval 100
<RouterA>import-route direct
<RouterA>silent-interface LoopBack0
<RouterA>spf-schedule-interval millisecond 200
<RouterA>lsa-originate-interval 0
<RouterA>lsa-arrival-interval 0
<RouterA>bandwidth-reference 100000
<RouterA>area 0.0.0.0

4. Configure the OSPFv3 (IPv6) process

<RouterA>ospfv3 8888
<RouterA>router-id 172.16.1.1
<RouterA>spf-schedule-interval millisecond 200
<RouterA>lsa-originate-interval 0
<RouterA>lsa-arrival-interval 0
<RouterA>bfd all-interfaces min-transmit-interval 100
<RouterA>area 0.0.0.0

5. Configure OSPF in the interface

<RouterA>interface Eth-Trunk1
<RouterA>ospfv3 8888 area 0.0.0.0
<RouterA>ospf authentication-mode md5 1 cipher <passwordhere>
<RouterA>ospf network-type p2p
<RouterA>ospf bfd enable
<RouterA>ospf bfd min-rx-interval 100
<RouterA>ospf enable 8888 area 0.0.0.0

Verification:

<RouterA>display ospf interface
<RouterA>display ospf topology
<RouterA>display ospf routing
<RouterA>display ospf brief
<RouterA>display ospf peer

 

RouterB Configuration:

<RouterB>interface 100GE6/0/0
<RouterB>description Connection to RouterA
<RouterB>undo shutdown
<RouterB>eth-trunk 1
<RouterB>undo lldp enable
<RouterB>undo dcn

2. Configure the Eth-Trunk IPv4/IPv6 address

<RouterB>interface Eth-Trunk1
<RouterB>description Eth-Trunk to RouterA
<RouterB>ipv6 enable
<RouterB>ip address 192.168.10.2 255.255.255.252
<RouterB>ipv6 address fdfe:13bb:8abc:a00:8::2b/127
<RouterB>mode lacp-static

3. Configure the OSPF (IPv4) process (with optional parameters)

<RouterB>ospf 8888 router-id 172.16.1.2
<RouterB>bfd all-interfaces min-tx-interval 100 min-rx-interval 100
<RouterB>import-route direct
<RouterB>silent-interface LoopBack0
<RouterB>spf-schedule-interval millisecond 200
<RouterB>lsa-originate-interval 0
<RouterB>lsa-arrival-interval 0
<RouterB>bandwidth-reference 100000
<RouterB>area 0.0.0.0

4. Configure the OSPFv3 (IPv6) process

<RouterB>ospfv3 8888
<RouterB>router-id 172.16.1.2
<RouterB>spf-schedule-interval millisecond 200
<RouterB>lsa-originate-interval 0
<RouterB>lsa-arrival-interval 0
<RouterB>bfd all-interfaces min-transmit-interval 100
<RouterB>area 0.0.0.0

5. Configure OSPF in the interface

<RouterB>interface Eth-Trunk1
<RouterB>ospfv3 8888 area 0.0.0.0
<RouterB>ospf authentication-mode md5 1 cipher <passwordhere>
<RouterB>ospf network-type p2p
<RouterB>ospf bfd enable
<RouterB>ospf bfd min-rx-interval 100
<RouterB>ospf enable 8888 area 0.0.0.0

 

Verification:

<RouterB>display ospf interface
<RouterB>display ospf topology
<RouterB>display ospf routing
<RouterB>display ospf brief
<RouterB>display ospf peer

Sample Output:

<RouterA>display ospf peer

(M) Indicates MADJ neighbor
OSPF Process 55430 with Router ID 172.16.1.1
Neighbors

Area 0.0.0.0 interface 192.168.10.2 (Eth-Trunk1)’s neighbors
Router ID: 172.16.1.1 Address: 192.168.10.1
State: Full Mode:Nbr is Master Priority: 1
DR: None BDR: None MTU: 0
Dead timer due in 39 sec
Retrans timer interval: 5
Neighbor is up for 66h39m58s
Neighbor Up Time : 2022-05-20 15:44:50+08:00
Authentication Sequence: [ 240040 ]

Be First to Comment

Leave a Reply

Your email address will not be published.