VLAN and Port-Channel Configuration (Cisco to Juniper Conversion)

Scenario:
2 physical interfaces bundled together (port-channel) and associated in the same vlan.

Tested in:
Cisco Nexus
Juniper EX Series

Steps

Cisco

Juniper

Configure 2 physical interfaces interface Ethernet1/1
description Server Link#1
switchport
switchport access vlan 888
channel-group 99 mode active
no shutdown

interface Ethernet2/1
description Server Link#2
switchport
switchport access vlan 888
channel-group 99 mode active
no shutdown
#set interfaces xe-0/0/0 description ” Server Link#1 “
#set interfaces xe-0/0/0 gigether-options 802.3ad ae99

#set interfaces xe-1/0/0 description ” Server Link#2 “
#set interfaces xe-1/0/0 gigether-options 802.3ad ae99
Configure the port-channel interface port-channel99
description Server Port-channel
switchport
switchport access vlan 888
#set interfaces ae99 description ” Server Port-channel “
#set interfaces ae99 aggregated-ether-options lacp active
#set interfaces ae99 unit 0 family ethernet-switching interface-mode access
#set interfaces ae99 unit 0 family ethernet-switching vlan members VLAN-888
Configure VLAN interface Vlan888
description Server-VLAN
no shutdown
ip address 192.168.20.193/26
#set interfaces irb unit 888 description ” Server-VLAN”
#set interfaces irb unit 888 family inet address 192.168.20.193/26
#set vlans VLAN-888 l3-interface irb.888
Verify Interface #show int Eth1/1
Ethernet1/1 is up
admin state is up, Dedicated Interface
Belongs to Po99

#show int Eth2/1
Ethernet2/1 is up
admin state is up, Dedicated Interface
Belongs to Po99
#show interfaces xe-0/0/0
Physical interface: xe-3/0/0, Enabled, Physical link is Up

#show interfaces xe-1/0/0
Physical interface: xe-3/0/0, Enabled, Physical link is Up
Verify Port-Channel #show int port-channel99
port-channel99 is up
admin state is up

#show lacp port-channel interface port-channel 99
port-channel99
System Mac=aa-bb-cc-11-22-33
Local System Identifier=0x8000, aa-bb-cc-11-22-33
Admin key=0x1d
Operational key=0x1d
Partner System Identifier=0x8000,dd-ee-ff-44-55-66
Operational key=0x9
Max delay=0
Aggregate or individual=1
Member Port List=Eth1/1 Eth2/1
#show interfaces ae99
Physical interface: ae99, Enabled, Physical link is Up

#show lacp interfaces ae99
Aggregated interface: ae99
LACP state: Role Exp Def Dist Col Syn Aggr Timeout Activity
xe-0/0/0 Actor No No Yes Yes Yes Yes Fast Active
xe-0/0/0 Partner No No Yes Yes Yes Yes Slow Active
xe-1/0/0 Actor No No Yes Yes Yes Yes Fast Active
xe-1/0/0 Partner No No Yes Yes Yes Yes Slow Active
LACP protocol: Receive State Transmit State Mux State
xe-0/0/0 Current Slow periodic Collecting distributing
xe-1/0/0 Current Slow periodic Collecting distributing
Verify VLAN (show int vlan [xx])
show vlan brief
#show int vlan 888
Vlan888 is up, line protocol is up, autostate enabled

#show vlan brief
VLAN Name Status Ports
888 Server-VLAN active Po99, Eth1/1, Eth2/1
#show interfaces irb.888
Logical interface irb.888 (Index 123) (SNMP ifIndex 456)

#show vlans
Routing instance VLAN name Tag Interfaces
default-switch VLAN-888 888
ae99.0*

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *