Converting Physical to Bundle interface (LACP) on Juniper Routers

This is a sample steps of migrating IP configuration from physical interface to bundle interface. Take note that this may result service impact during the migration as the existing interface need to be shutdown and re-configure. Remember to shift your traffic prior with the maintenance.

Existing Config:

freenetwork@MX1-re0> show configuration interfaces et-0/0/1
description “Link to Switch1”;
unit 0 {
family inet {
address 192.168.0.1/24;
}
family inet6 {
address fdf8:d3f5:1a47:bc09::1/64;
}

Fig.1

  1. Shutdown the physical interface and remove existing configuration

$configure

set interfaces et-0/0/1 disable
delete interfaces et-0/0/1

2. Configure bundle interface (ae77) and migrate the IP (Assuming the interface is 100G and lacp mode is active)

set interfaces ae77 description “Link to Switch1”
set interfaces ae77 aggregated-ether-options link-speed 100g
set interfaces ae77 aggregated-ether-options lacp active
set interfaces ae77 unit 0 family inet address 192.168.0.1/24
set interfaces ae77 unit 0 family inet6 address fdf8:d3f5:1a47:bc09::1/64

3. Add the physical interface into the bundle

set interfaces et-0/0/1 gigether-options 802.3ad ae77

Verify:

show interface et-0/0/1
show interface ae77
show lacp interfaces ae77
show arp interface ae77.0

Sample Output:
freenetwork@MX1-re0> show lacp interfaces ae77
Aggregated interface: ae77
LACP state: Role Exp Def Dist Col Syn Aggr Timeout Activity
et-0/0/1 Actor No No Yes Yes Yes Yes Fast Active
et-0/0/1 Partner No No Yes Yes Yes Yes Slow Active
LACP protocol: Receive State Transmit State Mux State
et-0/0/1 Current Slow periodic Collecting distributing
{master}

Fig.2

Note: Bundle is default as non-switchport so to bring up bundle (for testing purposes) without migrating the existing physical interface configuration, you can set it as L2 interface or as access mode.

set interfaces ae77 unit 0 family ethernet-switching interface-mode access

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *